Lagondaforum

Hello Guest! (New posts) Forum


Expand and collapse Topic Options
Pages (1): [1]
 Show first unread post

Nov 29, 2010 5:53 pm
mandb57 Offline
Member
Registered since: Dec 05, 2007
Location: Cheshire, England


Subject: Klaxon Horn (working intermittently)
The Klaxon horn fitted to our 2 Litre High Chassis tourer started to work intermittently a few years ago. Just over 2 years ago I took it off the car and tried to find the reason for the fault.

It appears there is some problem with the armature windings. When the horn is tested in the workshop the armature often stops in one position and will not restart of its own accord BUT if it is "prodded" with a screwdriver it bursts into life.

I sent the horn to a company who said they would test the armature out but I never managed to get them to do it so after 2 years I have now recovered the horn.

I dont think the Klaxon is original (it has plastic brush holder caps!) although it was on the car when I purchased it in the early 1980's.

I have looked at modern replacements but all the ones I have seen appear to look "cheap and nasty" with plastic parts.

Any ideas of what I should do next?

Thanks Mike Heins
Mike Heins
 

Dec 05, 2010 3:35 pm
Mike Fountain Offline
Member
Registered since: Jan 18, 2008
Location: -


Subject: Re: Klaxon Horn (working intermittently)
Mike you could find a replacement on e-bay they tend to go for about 70 or you could try and use the working parts from one of the "modern plastic" units and fit into your old hooter. I did this a year or so ago although it was into a rather large old horn. Good luck Mike
 

Pages (1): [1]


All times are GMT (Summertime)